Commit f44f3a6c authored by Diego Sueiro's avatar Diego Sueiro
Browse files

doc,ewaol-[config,distro]: Updates for v1.0 release



For the v1.0 release, this patch:
  * Sets DISTRO_VERSION to v1.0
  * Pins all dependent layers
  * Updates the documentation mentioning the v1.0 in the relevant sections

Issue-Id: SCM-4397
Signed-off-by: Diego Sueiro's avatarDiego Sueiro <diego.sueiro@arm.com>
Change-Id: Ibd05925030bce5d5c32d815a7199d91832bcd8bd
parent 08547a48
......@@ -58,7 +58,7 @@ EWAOL depends on the following layer dependency sources:
URL: https://git.openembedded.org/meta-openembedded
layers: meta-filesystems, meta-networking, meta-oe, meta-python
branch: |meta-openembedded branch|
revision: |meta-openembedded branch|
revision: |meta-openembedded revision|
URL: https://git.yoctoproject.org/git/meta-virtualization
layers: meta-virtualization
......
......@@ -41,7 +41,7 @@ distribution image:
meta-ewaol:
url: |meta-ewaol remote|
refspec: |meta-ewaol branch|
refspec: |meta-ewaol version|
machine: my-machine
......
......@@ -131,7 +131,7 @@ The ``meta-ewaol`` repository can be downloaded using Git, via:
mkdir -p ~/ewaol
cd ~/ewaol
git clone |meta-ewaol remote| --branch |meta-ewaol branch|
git clone |meta-ewaol remote| --branch |meta-ewaol version|
cd meta-ewaol
.. _user_guide_reproduce_build:
......
......@@ -29,6 +29,7 @@ yocto_doc_version = "4.0/"
yocto_linux_version = "5.15"
xen_version = "4.16"
kas_version = "3.0.2"
ewaol_version = "v1.0"
general_links = {
"link:Yocto Project Documentation": f"https://docs.yoctoproject.org/{yocto_doc_version}",
......@@ -71,15 +72,16 @@ layer_definitions = {
"meta-ewaol repository host": "https://gitlab.arm.com",
"meta-ewaol remote": "https://git.gitlab.arm.com/ewaol/meta-ewaol.git",
"meta-ewaol branch": f"{yocto_release}-dev",
"meta-ewaol version": f"{ewaol_version}",
"poky branch": f"{yocto_release}",
"meta-openembedded branch": f"{yocto_release}",
"meta-virtualization branch": f"{yocto_release}",
"meta-arm branch": f"{yocto_release}",
"poky revision": "HEAD",
"meta-virtualization revision": "HEAD",
"meta-openembedded revision": "HEAD",
"meta-arm revision": "HEAD",
"layer dependency statement": f"The layer revisions are related to the EWAOL ``{yocto_release}-dev`` branch.",
"poky revision": "453be4d258f71855205f45599eea04589eb4a369",
"meta-virtualization revision": "2fae71cdf0e8c6f398f51219bdf31eac76c662ec",
"meta-openembedded revision": "166ef8dbb14ad98b2094a77fcf352f6c63d5abf2",
"meta-arm revision": "fc09cc0e8db287600625e64905170a6de24f2686",
"layer dependency statement": f"The layer revisions are related to the EWAOL ``{ewaol_version}`` release.",
}
other_definitions = {
......
......@@ -3,7 +3,7 @@
# SPDX-License-Identifier: MIT
######################
# EWAOL Next Release #
# EWAOL v1.0 Release #
######################
---
......@@ -13,9 +13,13 @@ header:
repos:
meta-arm:
refspec: fc09cc0e8db287600625e64905170a6de24f2686
meta-openembedded:
refspec: 166ef8dbb14ad98b2094a77fcf352f6c63d5abf2
meta-virtualization:
refspec: 2fae71cdf0e8c6f398f51219bdf31eac76c662ec
poky:
refspec: 453be4d258f71855205f45599eea04589eb4a369
......@@ -7,7 +7,7 @@ require ${COREBASE}/meta-poky/conf/distro/poky.conf
# Introduce the EWAOL Yocto Distro
DISTRO = "ewaol"
DISTRO_NAME = "EWAOL (Edge Workload Abstraction and Orchestration Layer)"
DISTRO_VERSION = "unstable"
DISTRO_VERSION = "v1.0"
# systemd as the init system
INIT_MANAGER = "systemd"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment